PDA

View Full Version : Possible Bug


Optumystic
07-24-2009, 08:23 PM
The date displayed next to the weather does not update for me except after battle.

I have tried screen refreshes, logging out but they do not work. I didn't even realize time was going by until I got the scout reports and they were dated.

While definitely not a show stopper, you can't fix anything unless you know it is broke. :) (if it is broke even, might be working as intended)

Merlin
07-25-2009, 12:46 AM
It is working as intended. What is supposed to happen is that when we implement weather, it won't change during a battle. It wouldn't make any sense for the weather to change from rain to heavy rain to snow during a two hour battle.

There are a couple of details to work out, but that's the idea.

Optumystic
07-25-2009, 01:45 AM
I think maybe I didn't explain it well.

The date being displayed is 28 Avrilia 1250 Q.J.

I just got a message saying:

Messages: 29 Avrilia 1250 Q.J. 1 PM
A scout has reported that a group of bandits is marching nearby. They are to the west of you.

This is an example as it is just happening. When I first reported what I view as a discrepancy, the difference was about 28 days. The date displayed to me does not increment at all unless I fight, but the date keeps marching on in the messages I receive.

Merlin
07-26-2009, 04:41 PM
I think you're seeing the discrepancy between the world date, which advances by weeks, and the region clock, which advances by hours up through the week.

Optumystic
07-26-2009, 08:36 PM
OK, that makes sense. I just didn't realize that is how it works. My world date still seems to only update after a battle but it is possible that it updates weekly. I wasn't paying that much attention. I just noticed it was not updating with the messages.

Eudrick
07-26-2009, 10:43 PM
I complained loud and long about that when the city updates were monthly only (missing the 1st of the month was a real pain) but now that the city's production is weekly it's pretty much a non-issue.

Merlin
07-27-2009, 12:15 AM
I complained loud and long about that when the city updates were monthly only (missing the 1st of the month was a real pain) but now that the city's production is weekly it's pretty much a non-issue.
Yes, you are a complainer. ;)

Eudrick
07-27-2009, 12:08 PM
But that's why you keep me around.

Optumystic
07-27-2009, 07:19 PM
But that's why you keep me around.

That and your $1 a month. :P

Braken
07-27-2009, 07:23 PM
The one dollar might be the only reason :D .

Optumystic
07-27-2009, 09:09 PM
Hey Braken, how come you only have a population of 8? You almost have more forum posts than you do gobbie citizens.

Braken
07-27-2009, 10:46 PM
I only got to start my city but my computer is too slow for me. I waited an hour and half the map was loaded

Braken
07-27-2009, 10:47 PM
And this link ↓ I realy wanted you to click

Merlin
07-28-2009, 12:21 AM
A dollar? Do you expect us to give him a raise?

Eudrick
07-28-2009, 12:32 AM
A dollar? Do you expect us to give him a raise?

Read the NPG. I REALLY do work for beer and pretzels.

Braken
07-28-2009, 01:00 AM
Wow this is going from a possible bug to money to working for pretzels and beer. '_' :p

Optumystic
07-28-2009, 07:06 AM
I only got to start my city but my computer is too slow for me. I waited an hour and half the map was loaded

Maybe the code needs to be optimized for a Nintendo DSI. I think it works amazing well on your 'computer'. I bet it was never meant to work on that little machine you use.